Visa has confirmed the delayed settlement notifications are tied to a migration on their back end that completed today (2026-03-02). They've started to backfill the delayed notifications with an expectation that this will complete by the end of the week. No data will be lost.
We're keeping an eye on the transactions and will follow up once we've confirmed the backfill is complete. Please reach out via slack if you have any questions.
In progress
Visa has confirmed the delayed settlement notifications are tied to a migration on their back end that completed today (2026-03-02). They've started to backfill the delayed notifications with an expectation that this will complete by the end of the week. No data will be lost.
We're keeping an eye on the transactions and will follow up once we've confirmed the backfill is complete. Please reach out via slack if you have any questions.
In progress
We have identified a gap in Visa settlement notifications between February 24 and February 26, 2026. During this period, Visa's platform did not deliver settlement notifications for single-enrolled cards, while authorization notifications continued without interruption. Cards enrolled via bulk feed are not affected.
This means transactions on single-enrolled cards that have pending authorizations may not yet show a corresponding settlement record in the expected timeframe. No data has been lost — we expect the missing settlement records to be backfilled by Visa over the coming days.
We are in communication with Visa regarding this delivery gap and are actively tracking the resolution. We will provide an update once the backfill is confirmed complete.
Affected services: Clearing / Settlement Notifications